Utilizamos cookies propias y de terceros para ofrecer nuestros servicios y recoger datos estadísticos. Continuar navegando implica su aceptación. Más información

Aceptar
Excel
Volver

Cómo detectar y eliminar datos repetidos en Excel

19-04-2020
Cómo detectar y eliminar datos repetidos en Excel

Es uno de los problemas más habituales, tenemos dos listas de datos interminables y necesitamos saber si algunos de los registros se encuentran en las dos. Contarlos manualmente no es la opción, y más si las listas son medianamente largas. Hay muchas formas de encontrar repetidos en excel, hoy os explicaremos dos de ellas, una con la función CONTAR.SI y otra con las funciones BUSCARV y SI.ERROR.

Detectar valores repetidos en Excel con la función CONTAR.SI

Lo primero que haremos es poner las dos listas juntas para que el resultado sea lo más visual y sencillo posible. En este ejemplo sencillo tenemos dos columnas, una con empleados del turno A y otra con empleados del turno B.

Haremos una tercera columna que contará los valores repetidos. Si el resultado de esta fórmula es 0, significará que no hay valores repetidos, si es superior a cero nos indicará el número de veces que el empleado está repetido. La fórmula CONTAR.SI es la siguiente:

=CONTAR.SI (rango; criterio)

En nuestro ejemplo la usaremos de la siguiente forma:

=CONTAR.SI($B$7:$B$13;C7)

El rango B7:B13 contiene los empleados A, de forma que contará las veces que se repite el valor de la celda C7, el nombre del primer empleado del turno B. Para ver el resultado en todos los empleados arrastramos la fórmula desde la celda D8 hasta la D13.

Detectar valores repetidos en Excel con la función BUSCARV

Otra forma es utilizando la función BUSCARV de la que ya hemos hablado en otras ocasiones. Lo que hará esta función es buscar el valor del empleado del turno B, en la columna con los empleados del turno A, si lo encuentra devolverá el nombre del empleado, si no lo encuentra devolverá el error #N/D.

=BUSCARV(Valor_buscado;Matriz_tabla;Indicador de columnas;Rango)

En nuestro caso la usaremos de la siguiente forma:

= BUSCARV(C7;$B$7:$B$13;1;FALSO)

Donde C7 es el valor del empleado del turno B que estamos evaluando si tiene repetición, el rango B7:B13 es el rango de empleados del turno A donde estamos buscando los duplicados, el indicador de columnas es el número de columna del rango de los empleados del turno A, en este caso sólo tiene una columna y, por último, FALSO, porque queremos que nos devuelva la coincidencia exacta, y no un nombre parecido.

Como no queremos que nos devuelva error en caso de que no encuentre una coincidencia, utilizaremos la función SI. ERROR, que funciona de la siguiente forma:

= SI.ERROR(Valor;Valor_si_error)

Donde fundamentalmente le decimos a Excel que queremos que ponga en caso de que la formula de error. En este caso queremos que ponga un espacio en blanco, así que pondremos “” en el campo Valor_si_error, de forma que la fórmula final quedará:

= SI.ERROR(BUSCARV(C7;$B$7:$B$13;1;FALSO);"")

Ahora sólo hay que arrastrar la fórmula desde la celda D7 hasta la D13 para obtener los repetidos de todos los empleados del turno B.

Contacto

Envíanos tus datos y nos pondremos en contacto contigo.

INFORMACIÓN PROTECCIÓN DE DATOS. Finalidades: Responder a sus solicitudes y remitirle información comercial de nuestros productos y servicios, incluso por correo electrónico. Legitimación: Consentimiento del interesado. Destinatarios: No están previstas cesiones de datos. Derechos: Puede retirar su consentimiento en cualquier momento, así como acceder, rectificar, suprimir sus datos y demás derechos en info@plantillaspyme.com.  Información Adicional: puede ampliar la información en Política de Privacidad