Cómo detectar y eliminar datos repetidos en Excel

Es uno de los problemas más habituales, tenemos dos listas de datos interminables y necesitamos saber si algunos de los registros se encuentran en las dos. Contarlos manualmente no es la opción, y más si las listas son medianamente largas. Hay muchas formas de encontrar repetidos en excel, hoy os explicaremos dos de ellas, una con la función CONTAR.SI y otra con las funciones BUSCARV y SI.ERROR.

Detectar valores repetidos en Excel con la función CONTAR.SI

Lo primero que haremos es poner las dos listas juntas para que el resultado sea lo más visual y sencillo posible. En este ejemplo sencillo tenemos dos columnas, una con empleados del turno A y otra con empleados del turno B.

Haremos una tercera columna que contará los valores repetidos. Si el resultado de esta fórmula es 0, significará que no hay valores repetidos, si es superior a cero nos indicará el número de veces que el empleado está repetido. La fórmula CONTAR.SI es la siguiente:

=CONTAR.SI (rango; criterio)

En nuestro ejemplo la usaremos de la siguiente forma:

=CONTAR.SI($B$7:$B$13;C7)

El rango B7:B13 contiene los empleados A, de forma que contará las veces que se repite el valor de la celda C7, el nombre del primer empleado del turno B. Para ver el resultado en todos los empleados arrastramos la fórmula desde la celda D8 hasta la D13.

Detectar valores repetidos en Excel con la función BUSCARV

Otra forma es utilizando la función BUSCARV de la que ya hemos hablado en otras ocasiones. Lo que hará esta función es buscar el valor del empleado del turno B, en la columna con los empleados del turno A, si lo encuentra devolverá el nombre del empleado, si no lo encuentra devolverá el error #N/D.

=BUSCARV(Valor_buscado;Matriz_tabla;Indicador de columnas;Rango)

En nuestro caso la usaremos de la siguiente forma:

= BUSCARV(C7;$B$7:$B$13;1;FALSO)

Donde C7 es el valor del empleado del turno B que estamos evaluando si tiene repetición, el rango B7:B13 es el rango de empleados del turno A donde estamos buscando los duplicados, el indicador de columnas es el número de columna del rango de los empleados del turno A, en este caso sólo tiene una columna y, por último, FALSO, porque queremos que nos devuelva la coincidencia exacta, y no un nombre parecido.

Como no queremos que nos devuelva error en caso de que no encuentre una coincidencia, utilizaremos la función SI. ERROR, que funciona de la siguiente forma:

= SI.ERROR(Valor;Valor_si_error)

Donde fundamentalmente le decimos a Excel que queremos que ponga en caso de que la formula de error. En este caso queremos que ponga un espacio en blanco, así que pondremos “” en el campo Valor_si_error, de forma que la fórmula final quedará:

= SI.ERROR(BUSCARV(C7;$B$7:$B$13;1;FALSO);"")

Ahora sólo hay que arrastrar la fórmula desde la celda D7 hasta la D13 para obtener los repetidos de todos los empleados del turno B.



Si quieres aprender a dominar Excel de principio a fin, te recomendamos el curso de Excel que tenemos en la sección de administración, un curso totalmente completo con el que aprenderás desde las funcionalidades más básicas, como ingresar fórmulas y desplazarse por Excel, hasta las más avanzadas como los gráficos y tablas dinámicas o la conexión de Excel con datos externos, entre otros.

Plantillas relacionadas

Debes estar registrado

Curso de Excel

24,75 €

Debes estar registrado

Gráficos en Excel

10,70 €

Debes estar registrado

Seguimiento mensual de balances

12,36 €

Debes estar registrado
-770,21 €

Todas las plantillas

1.098,31 € 328,10 €

Artículos relacionados

Probablemente conozcas el significado de esta palabra sin que tengamos que dar demasiadas explicaciones. Efectivamente, el stock no es más que el...

Todos los empleados reciben una nómina de su empresa con la información acerca de su retribución económica. Esta se calcula según el periodo de...

Este 2020 ha empezado con mucho movimiento, y promete seguir siendo un año muy agitado en el que conviene estar preparado, así que hoy vamos a...